FAQ
What are the System Requirements for Babylon for MAC?

The system requirements depend on which version of the Babylon software you are using.

 

 

Babylon V3.1 Requirements:

 

  • Multicore Intel® processor
  • Mac OS X v10.5 and above  
  • 1GB of RAM
  • 50MB of available hard-disk space for installation; additional free space required after installation to add Babylon glossaries (it cannot be installed on removable flash storage devices)
  • Graphics card with updated drivers
  • Broadband Internet connection required for online services
  • Works on \ compatible with: O-Office, Safari 4.x. 

 

To download version 3.1, click here.

 

V3 Requirements:

 

  • Multicore Intel® processor
  • Mac OS X v10.5 and above  
  • 1GB of RAM
  • 50MB of available hard-disk space for installation; additional free space required after installation to add Babylon glossaries (it cannot be installed on removable flash storage devices)
  • Graphics card with latest updated drivers
  • Broadband Internet connection required for online services
  • Works on \ compatible with: O-Office, Safari 4 \ 5.

 

 V2 Requirements:

 

  • Multicore Intel® processor
  • Mac OS X 10.5.X - 10.6.X
  • 1GB of RAM
  • 50MB of available hard-disk space for installation; additional free space required after installation to add Babylon glossaries (it cannot be installed on removable flash storage devices)
  • Graphics card with latest updated drivers
  • Broadband Internet connection required for online services
  • Works on \ compatible with: O-Office, Safari 4.

 

To download version 2, click here.



Back to Questions