Buy Babylon
FAQ
What are the Babylon System Requirements for Windows?

The system requirements depend on which version of Babylon you are using.

 

Babylon 10 Requirements:

 

  • Intel® Core™2 Duo or AMD Phenom® II processor
  • 32-bit & 64-bit operating system required: Microsoft® Vista, Windows® 7, Windows® 8.x, Windows® 10
  • 1GB of RAM (2GB or more recommended)
  • 100MB of available hard-disk space for installation; additional free space required after installation to add Babylon glossaries
  • Adobe® Flash® Player 
  • Sound card
  • Broadband Internet connection required for online services

 

Works on \ compatible with  : 

 

  • Word ,Excel ,Power Point ,Outlook 2003 \ 2007 \ 2010 \ 2013
  • For Document Translation, Office 2007 and above.
  • Internet Explorer 7.x and Above
  • Firefox 3.x and above
  • Google Chrome 5 and above
  • Adobe® Reader 8.x - 11.x

 

Babylon 9 Requirements:

 

  • Intel® Core™2 Duo or AMD Phenom® II processor
  • 32-bit & 64-bit operating system required: Microsoft® Vista or Windows® 7
  • 1GB of RAM (2GB or more recommended)
  • 100MB of available hard-disk space for installation; additional free space required after installation to add Babylon glossaries
  • Adobe® Flash® Player 
  • Sound card
  • Broadband Internet connection required for online services

 

Works on \ compatible with  : 

 

  • Word ,Excel ,Power Point ,Outlook 2003 \ 2007 \ 2010
  • Internet Explorer 7.x - 9.X
  • Firefox 3.x - 19.x
  • Google Chrome 5 - 25.x
  • Adobe® Reader 8.x - 10.x

 

 

Babylon 8 Requirements:

 

  • Intel® Core™2 Duo or AMD Phenom® II processor
  • 32-bit operating system required: Microsoft® Vista 
  • 1GB of RAM (2GB or more recommended)
  • 100MB of available hard-disk space for installation; additional free space required after installation to add Babylon
  • Adobe® Flash® Player 
  • Sound card
  • Broadband Internet connection required for online services

 

Works on \ compatible with  : 

 

  • Word ,Excel ,Power Point ,Outlook 2003 \ 2007 
  • Internet Explorer 6.x - 8.x only  
  • Firefox 2.x -3.5 only
  • Google Chrome 5.x - 8.x only
  • Adobe® Reader 8.x - 9.x only

 

Babylon 7 and lower Requirements:

 

  • Intel® Core™2 Duo or AMD Phenom® II processor
  • 32-bit operating system required: Microsoft® XP
  • 512MB of RAM (1GB or more recommended)
  • 50MB of available hard-disk space for installation; additional free space required after installation to add Babylon glossaries
  • Adobe® Flash® Player 
  • Sound card
  • Broadband Internet connection required for online services

 

Works on \ compatible with  : 

 

  • Word, Excel,Power Point ,Outlook 2003 
  • Internet Explorer 6.x - 7.x only.
  • Firefox 2.x - 3.0 only.
  • Google Chrome Not Supported.
  • Adobe® Reader 7.x only.


Back to Questions